Potential Kin Online Search issue

Incident Report for Binti

Resolved

This issue has been resolved.
Posted Aug 17, 2026 - 11:51 PDT

Update

We are working with Thomson Reuters/Clear to continue to investigate this issue and will post updates here as we have them.
Posted Aug 14, 2026 - 08:43 PDT

Investigating

Potential Kin Online Search is temporarily unavailable. We are actively working to resolve the issue. Please check back soon.
Posted Aug 13, 2026 - 15:54 PDT
This incident affected: Binti Family Web Page.