Binti Downtime
Incident Report for Binti
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 13:42 PDT
Investigating
We are currently investigating this issue.
Posted Mar 16, 2023 - 13:18 PDT
This incident affected: Binti Family Web Page.