We’re currently investigating reports of challenges logging into Binti.
Incident Report for Binti
Resolved
Users are able to log into Binti. Thank you for your patience.
Posted Jul 25, 2024 - 14:54 PDT
Identified
Our engineers identified the issue and are working on a fix. If you are subscribed to email updates, we will not send another update until the status changes.
Posted Jul 25, 2024 - 11:42 PDT
Investigating
We are currently investigating this issue.
Posted Jul 25, 2024 - 10:08 PDT
This incident affected: Binti Family Web Page.